Error on XAMPP 1.8.0 PHP 5.4.4

Problems with basic installation

Error on XAMPP 1.8.0 PHP 5.4.4

Postby knuzen » Fri Aug 24, 2012 4:21 pm

When I start Installation I get this messages on top of the screen:

Strict Standards: Non-static method Jaws_Request::getInstance() should not be called statically in C:\xampp\htdocs\jaws\install\index.php on line 71

Strict Standards: Non-static method Jaws_Utils::GetLanguagesList() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\jaws\install\stages\Introduction.php on line 40

Strict Standards: Non-static method Jaws_Utils::getBaseURL() should not be called statically, assuming $this from incompatible context in C:\xampp\htdocs\jaws\include\Jaws\Template.php on line 295

Strict Standards: Only variables should be passed by reference in C:\xampp\htdocs\jaws\include\Jaws\Utils.php on line 79

Strict Standards: Non-static method Jaws_Utils::getBaseURL() should not be called statically in C:\xampp\htdocs\jaws\install\index.php on line 200
----
And then the normal Introduction 1..8
It would be great to test JWAS first on xampp, but this messages get more and more ...
Do you please have a hint ?
knuzen
 
Posts: 4
Joined: Tue Aug 21, 2012 3:26 pm
Location: Berlin, Germany

Re: Error on XAMPP 1.8.0 PHP 5.4.4

Postby mkh » Fri Aug 24, 2012 4:34 pm

Just turn off error reporting for deprecated messages on your php.ini:
Code: Select all
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED


Note: We have to support PHP 5.2 in Jaws 0.8 series for compatibility but no longer in Jaws 0.9.
mkh
 
Posts: 36
Joined: Sat Apr 19, 2008 4:51 pm
Location: Tehran, Iran

Re: Error on XAMPP 1.8.0 PHP 5.4.4

Postby knuzen » Sat Aug 25, 2012 4:45 pm

Oh great, thanks a lot, it's now fixed.

BUT after that I get errormessages while installing MYSQL.
Anyway!

So I decided to use better the previous Version of xampp-win32-1.7.3
because here everything works fine at once. :D
knuzen
 
Posts: 4
Joined: Tue Aug 21, 2012 3:26 pm
Location: Berlin, Germany

Re: Error on XAMPP 1.8.0 PHP 5.4.4

Postby zaza » Sun Jul 14, 2013 11:49 am

I am getting these horrible errors all over the place too.

What/where is php.ini?
meh.
zaza
 
Posts: 1
Joined: Sun May 26, 2013 8:01 am


Return to Installation

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron