Installing from trunk (10687)

Discussion about issues with current development version

Installing from trunk (10687)

Postby Agustin » Fri Mar 27, 2009 3:48 pm

Hi Everybody, my name is Agustin, im from Argentina.
Im a developer in an european company, well, really, in their outsourcing sub-company.
My english is not perfect, but i can communicate my ideas.

I want to learn and develop gadgets and stuff. i NEED a way to share gadgets between websites, so i took a look on the share gadget in the trunk version. its a great idea, i tried to adapt it to the stable version (some class names are differents and stuff) but it didnt work. The i saw another great things like the comments gadget and i said "wow, i want this version, is so much better than stable".
Unfortunately all that was reading the code, when i tried to install trunk jaws to try it i get this:

Code: Select all

Warning: Missing argument 1 for JawsInstaller::JawsInstaller(), called in /home/orphalese/Servidor/jaws_svn/install/index.php on line 102 and defined in /home/orphalese/Servidor/jaws_svn/install/JawsInstaller.php on line 39

Notice: Undefined variable: path in /home/orphalese/Servidor/jaws_svn/install/JawsInstaller.php on line 41

Notice: Array to string conversion in /home/orphalese/Servidor/jaws_svn/install/JawsInstaller.php on line 116
Ooops!
Ooops! something weird happened to your Jaws!

The stage list couldn't be found at Array.


Do you know what is happening?

ALSO, and as a way to say HI, here is a new template, i dont know how send this to who-must-validate-contributions so i will attach it here now,
Nice to meet you all guys, i think Jaws is a great cms-framework and im so happy to work with it, its like an orgasmic experience like the one i had with codeigniter, but it is useful for another completely different things.

------------------------------------------------------------------------------------------------------------------------------
UPDATE: ok, im finding the error without idea of whats happening.
I find something and changed the code to this:

Jawsinstaller.php, function LoadStages
Code: Select all
    /**
     * Loads the list of stages available from a stage list file.
     *
     * @access  public
     * @param   string The file to load the stages from.
     * @return  bool|Jaws_Error
     */
    function LoadStages($list)
    {
      /* if (!file_exists($list)) {
            Jaws_Error::Fatal("The stage list couldn't be found at <strong>${list}</strong>.", __FILE__, __LINE__);
        }

        include_once $list;*/

// $list is not a filename is already a list of stages, so i tried this:

        $stages = $list;

// and it worked.
       
        foreach ($stages as $stage) {
            if (isset($stage['name']) && isset($stage['file'])) {
                $this->LoadStage($stage, false);
            }
        }
    }
}



Update2:
Linkdump gadget is not updated

gadgets/LinkDump/Info.php on line 12
Code: Select all
class LinkDumpInfo extends Jaws_GadgetInfo -> class LinkDumpInfo extends Jaws_Gadget_Info


(ive added a small piece of code in include/Jaws/Error.php to debug faster, because i dont know where the bug is)
Code: Select all
    function Fatal($message, $file, $line)
    {
        //FIXME: And what will happen when it's being called from a WS?
        if (isset($GLOBALS['log'])) {
            $GLOBALS['log']->Log(JAWS_LOG_ERR, "[Fatal Error]\n $message  : " . __FILE__ . ':' . __LINE__);
/* Is this right? .or maybe something like:
            $GLOBALS['log']->Log(JAWS_LOG_ERR, "[Fatal Error]\n $message  : " . $file . ':' . $line);
*/
        }

        if (defined('DEBUG_ACTIVATED') && DEBUG_ACTIVATED) {
            echo '<b style="color: #f00;"> JAWS Fatal Error:</b><br /><b>Page: </b>' .
                $file . "<br /><b>Line: </b>" . $line . "<br />" . $message;
            if (isset($GLOBALS['log'])) {
                $GLOBALS['log']->LogStackToScreen();
            }
        } else {
            //Get content
            $content = file_get_contents(JAWS_PATH . 'gadgets/ControlPanel/templates/FatalError.html');
           
            //This could be better, by modfying template, this is just a workaround.
            $message =  $message."
            <!--
               FILE: ".$file."
               LINE: ".$line."     
            --> ";
            $content = str_replace('{message}', $message, $content);
            echo $content;           
            exit;
        }

        exit;
    }
}


Update3:
In the settings stage
Ooops! something weird happened to your Jaws!

Template /home/orphalese/Servidor/jaws_svn/gadgets/stages/Settings//templates/display.html doesn't exists.
A possible reason of this error is that the theme: is missing


The problem is in the way that function Load() in include/Jaws/Template.php decides if we are inside a gadget or not. We are not inside a gadget but i dont know enough of Jaws to know what is wrong and why it thinks we are in a gadget. So as a workaround, i put the string by myself (ugly, i know, i hope to learn to do this right with the time of learn the framework)

Now it happens again trying to save the settings, but now it cant find /home/orphalese/Servidor/jaws_svn/gadgets/stages/Settings//templates/display.html

And again after the configuration file: /home/orphalese/Servidor/jaws_svn/gadgets/stages/Finished//templates/display.html

And then the installation ends!!! yaaay!!!!

and now trying the index.php and the admin.php, both redirects me to /upgrade/index.php and crash with:
Warning: require_once(/home/orphalese/Servidor/jaws_svn/include/Jaws/GadgetInfo.php) [function.require-once]: failed to open stream: No such file or directory in /home/orphalese/Servidor/jaws_svn/upgrade/index.php on line 57

Fatal error: require_once() [function.require]: Failed opening required '/home/orphalese/Servidor/jaws_svn/include/Jaws/GadgetInfo.php' (include_path='.:/home/orphalese/Servidor/jaws_svn/libraries/pear') in /home/orphalese/Servidor/jaws_svn/upgrade/index.php on line 57


well at least its installed and i can continue looking around tomorrow.... i dont know if all this post is usefull or something, maybe is completely useless and its just a record of my firsts attempts in jaws. i want to help, but im learning about how
Attachments
urbanartist.zip
urbanartist from styleshout
(154.22 KiB) Downloaded 658 times
Agustin
 
Posts: 2
Joined: Fri Mar 13, 2009 8:53 pm

Return to Alpha and Beta Versions

Who is online

Users browsing this forum: No registered users and 2 guests

cron